cpanel email problem - 110 Can't open SMTP stream

ebykwee

New Email
Can't sent email from mailserver?

guys i have a problem with sending email from my mail-server(from Cpanel). every time i send an email, this error message appear:
ERROR:
Message not sent. Server replied:

Connection timed out
110 Can't open SMTP stream.

i've ask my web provider(hosting company), but he said the problem came from my computer. for information, i don't have problem sending email from microsoft outlook and from other email provider. what should i do?
please help me...:confused:
 

popowich

EQ Forum Admin
Staff member
Hello,

It appears that many cPanel users have run into this problem.

Do any of these solutions fix the problem for you?

I like all of you have been having the same problem. Here's how I fixed it.

# Block outgoing SMTP except for root, exim and mailman (forces scripts/users
# to use the exim/sendmail binary instead of sockets access). This replaces the
# protection as WHM > Tweak Settings > SMTP Tweaks. This will block hosting
# clients from using your server as an SMTP relay

SMTP_BLOCK = 1

# If SMTP_BLOCK is enabled but you want to allow local connections to port 25
# on the server (e.g. for web scripts) then enable this option too

SMTP_ALLOWLOCAL = 1

I originally had SMTP_ALLOWLOCAL = 0 and SMTP_BLOCK set to 1. The notes in the config make mention of local script access.

Worked for me with SquirrelMail's conf set to useSendmail = false;

If you have:

SMTP_BLOCK = 1

then

SMTP_ALLOWLOCAL should also be set to "1"

If Getting The 110 Can't Open SMTP Error:

Do this:

Edit the following file, and change useSendmail to true, instead of false:

/usr/local/cpanel/base/3rdparty/squirrelmail/config/config.php

Save this, and close it, but you must do the following so that cpanel doesn't change useSendmail back to false:

chattr +ai /usr/local/cpanel/base/3rdparty/squirrelmail/config/config.php

BTW, chattr is not a command on all operating systems, but it should be available on most linux servers.

-Raymond
 
Top