Exchange 2010 database won't mount - Error 0x6d9

Discussion in 'Microsoft Exchange' started by horsemas, Sep 16, 2015.

  1. horsemas

    horsemas New Email

    Sep 16, 2015
    Likes Received:
    Hi Experts,

    I am running a single Exchange 2010 server on Windows 2008 R2. It's been running fine, but tonight decided to apply some security updates to windows. After rebooting, the exchange databases (mailbox and public folders) came up dismounted. I uninstalled the security patches but they still won't mount. THANK YOU for any help!

    Trying to mount manually, I get this error:


    Microsoft Exchange Error


    Failed to mount database 'Exchange 2010 Mailbox Database'.

    Exchange 2010 Mailbox Database



    The RPC query to retrieve the copy status for Database Exchange 2010 Mailbox Database failed. The service might not be running. Error message: A server-side administrative operation has failed. The Microsoft Exchange Replication service may not be running on server Specific RPC error message: Error 0x6d9 (There are no more endpoints available from the endpoint mapper) from cli_GetCopyStatusEx2

  2. macmorley

    macmorley Greylisted

    May 26, 2015
    Likes Received:
    Hi dear,

    The RPC error code 0x6d9 is basically generated due to many reasons like may be your "Offline address Book" is no longer auto-updating. Well nothing to worry just check out these simple steps and follow the procedure, your issue will get resolved :-
    • Manually update the Offline address book via EMC
      • Open Organizational Configuration > Mailbox
      • click Offline Address Book > right click on Default Offline Address Book > click on Update
    • It may shows some error well nothing to worry . Start the Microsoft Exchange System Attendant service and your issue will get resolved.
    • But after rebooting the settings will get changed , hence delay the rebooting time after the commands mentioned above fails for 1st & 2nd time. Then set to "restart after service" for 5min.
    Or you can check out these steps also :-
    • Run EXBPA in the toolbox & DCDIAG
    • also run cmdlet
    • And create a New Database.
    • Set-
      • exchangeserver -identity servername -staticdomaincontrollers name -staticconfigdomaincontroller name -staticglobalcatalogs name
    • And also please set this following settings-
      • Set-ADServerSettings –PreferredServer <DC FQDN>
      • Set-Adsserversettings –preferredglobalcatalog <DC FQDN>
    Hope it might resolve your issue & if not then must ask for further assistance.


Want to reply or ask your own question?

It only takes a minute to sign up (and it's free!). Click the orange sign up button to choose a username and then you can ask your own questions on the forum.