Problems with links within emails

Pinpres

New Email
Hi,

I run a community website and contact my registered readers with 2 - 3 emails each month. Within the emails there is always a clickable link to the website. The emails are sent via Mailchimp (460 subscribers).

The problem that I have is that for the last couple of months, when some recipients click on the website link within the email, they are sent not to my website but to various inappropriate sites.

I believe that the is only happens on Android systems, and I have never seen it on my Windows PC or my iPhone.

Can anyone help, please?

Pinpres
 

popowich

EQ Forum Admin
Staff member
Are you running a wordpress site? Double check the htaccess, plugins, and site files for modifications that are redirecting visitors based on their device and/or web browser type. It happens sometimes with hacked sites that only specific types of users will be redirected because they match the malware on the evil site, or simply to help prevent the site admins from noticing. If you are Wordpress, they have a scanner that can help - Gravityscan - Free Website Security Scanner

That scanner will work for other types of web sites too. Also, I suspect this may be a problem for all of your visitors, not just those clicking through the mailchimp link. What does Google webmaster tools report for your site? Google Search Console

Those links should have the tools to help you start to figure out what the problem is.
 

popowich

EQ Forum Admin
Staff member
The WordFence team has a site cleaning option, they may be able to help you identify and fix the problem - Wordfence Site Cleanings - Wordfence

Before paying for their service I'd verify the problem is within your site. Do you know anyone with an android who can test going to your site and see if they get redirected when not following the mailchimp link?
 

Pinpres

New Email
I've tried a few things myself. If, on my own Android phone, I follow a link to my site which is contained in an email sent via Mailchimp I am sometimes redirected to the inappropriate site.

If I send myself an email with a link directly from one of my Gmail accounts to another - no problem.

If I enter the web address directly - no problem

???
 

popowich

EQ Forum Admin
Staff member
Do you mind sending me a private message with your web site address? Maybe it's a DNS problem and you have an extra bad record in there, maybe a web server behind a load balancer that's not configured for your site, that type of problem. I'll take a quick look and see if I can spot the problem.
 
Top