Old install suddenly stops recognizing relay

I have been running qmail for a long time, 15-20 years I guess. It has been running so smoothly that I have mostly forgotten what it takes to install and maintain it.

My setup involves a home server, home.xxx.com, and a linode.com server, xxx.com, as the main server. There's a local VPN connecting these, with /etc/hosts defining IP addresses for home.xxx.com and linode.xxx.com. All mail coming to xxx.com is forwarded to home.xxx.com over the VPN, and all outgoing mail from home.xxx.com is forwarded by home.xxx.com's qmail to linode.xxx.com's qmail. It's somewhat convoluted, but I live in the boonies, and before I had the current satellite connection, I was on dialup, and it couldn't stand the spam load. The satellite latency would probably cause its own problems, so I stick with the remote server.

This has been working for around ten years in the current configuration with no hiccups.

This morning, I tried sending an email, and it bounced back with "Sorry, I couldn't find any host named linode.xxx.com. (#5.1.2)". I tried sending email from outside, and it is held up by linode.xxx.com's qmail-send complaining it can't find the host home.xxx.com. Yet each can ping and ssh to each other.

I am at a loss to even have a clue on where to start looking. I rebooted; no change.

I did make one change right around the same time, which sure rings alarm bells, but I can't see any relationship. I run gentoo at home, and this morning removed some obsolete packages: net-libs/farsight2 and net-libs/telepathy-farsight. Near as I can tell, farsight is related to video and audio streaming, and I doubt qmail uses them. Nevertheless, I am in the middle of restoring them.

I don't see how it can be a DNS problem, since ping and ssh work by name. Ditto with the VPN.

Can someone suggest ways to figure out why these qmails refuse to recognize each other?
Solved: DNS registrar dropped the ball

Soon after I posted this question, ping and ssh began failing to find the domain, at different times on different remote computers.

It turns out the DNS registrar had dropped the ball, and while they were quite capable of sending adverts and renewal notices, they couldn't manage to tell me that ICANN was about to suspend the domain name for lack of up to date info.

Once I got that straightened out, qmail was happy again.

Like I said, I'm not an excellent sysadmin, and I do not understand why qmail was looking outside for addresses that are defined in /etc/hosts. But at least I know what the problem is now.