Email not received at verizon.net

andyw

Valued Member
Raymond,

I am using the php mail() function to send mail to accounts on gmail, onecommunications, and verizon.net. The first two are OK. The latter to verizon.net disappears. Not delivered, not in spam box. How do I troubleshoot when I can't figure out what happened to it?

Thanks again,

Andy
 

popowich

EQ Forum Admin
Staff member
Hi Andy,

Who is hosting the web site / php script?

What smtp server name and port settings are you using to send the email, or are they using whatever default the above web hosting is configured to use?

With the above I can check around and see if I notice any ISP X being blocked by ISP Y issues.
 

andyw

Valued Member
Ray,

Our ISP is onecommunications. I am with mhanp.org and simply using the ISP's default programs.

Thanks for the quick response.

Andy
 

popowich

EQ Forum Admin
Staff member
Hi Andy,

I don't see any emails from your domain to Verizon in the last couple of days.

Also, email is sending OK from the OneCom outgoing relays to Verizon.

I do see email from your domain sending to itself and to other domains including several emails with the subject (acronym for privacy) "WCA" sending to one of your addresses.

At this point I'd say double check the code that you think should be sending out emails to the Verizon addresses.

If you think there is an issue with the OneCom web hosting service please call their repair department at 888.832.5801.

:thanks: -Ray
 

popowich

EQ Forum Admin
Staff member
Did you figure out what the trouble was or is the email still not making it to the outgoing relays?
 

andyw

Valued Member
Still not making it to the outgoing relays.

I have created a small script that allows users to upload small changes to the web site by cell phone (they change dates, etc). These minor changes are to generate notices to a dozen managers via email.

I am testing the system by sending myself emails to several of my own accounts. The email addresses when entered into outlook, all arrive OK. However, when the php mail() script is used, the email address to verizon that works in Outlook, disappears. I don't know where it ends up.

I've been trying to communicate with Verizon but that is difficult and no luck yet.

At this point, I'm stuck.

Andy
 

popowich

EQ Forum Admin
Staff member
Check with OneCom and keep working with them until they can at least see the emails making it to their outgoing relays.

When I checked Verizon was not part of the problem, just getting the emails created and relayed out from the Linux hosting seemed to be the issue.
 

andyw

Valued Member
Ray,

Just spoke with onecom representative. His first response was that they have no equipment that creates my emails. I explained the fact that the php, pearl, mysql,etc are on his servers, part of the service he provides as ISP. I quoted your message about the problem being emails not being created and sent to the relay. That just confused him. He doesn't understand.

Being that I can't give him an error code, he won't make any effort to analyze my problem. He says Verizon is blocking my email.

I suggest that the mail is not being generated and sent on his end, he has no idea what I'm talking about.

Andy
 

popowich

EQ Forum Admin
Staff member
Hi Andy,

The ticket should make it's way to someone that can help in the morning.

-Raymond
 

andyw

Valued Member
Hi Ray,

Finally got the issue resolved. My 'Return-path' was being altered by an internal process causing Verizon to reject incoming.

An admin from onecom recognized this and showed me a work-a-round. Problem solved for good (I hope).

Sure is nice to have a young geek who knows what he's doing, watching my back.

Thanks, Ray.

Andy
 
Top