asterisk based pbx can not send email


EQ Forum Admin
Staff member
I received the following question by email :


Problem: My trixbox (astrerisk-based pbx for my business) has a feature that will allow the system to generate and send voicemails to am email address (wav file). I can also have it send me a text message when a message is left. All of this worked fine for years until March 20th. At that point it stopped working. In researching online,

Setup: CentOS using sendmail.
Email: Hosted via google apps

Here is what I CAN do after some testing:
I. From cli, I can do a command line sendmail test that works for POP accounts (ex:
II. "....... works for parts of ALIASES (ex -> & I do receive at but not the vtext.)
III. From within trixbox after the system generates an email, I can receive the email sent via sendmail to a POP account.

What I CANNOT do:
I. Trixbox generated emails to ALIASES never go through.
II. Direct emails to never work (in addition to when it is part of an alias)

Other notes:
- I cannot manage whitelists via google apps.
- I did send a piece of mail from and specified a ficticious email as a test in case it was blocked as spam. It didn't go through, BUT I did get a message failure returned (see attachment)
- Also, the name of the server is "" I did this a while back when having email problems when initially setting up this system. Apparently this can help incoming mail servers make the mail look more legit.

Thoughts, suggestions? I have ssh access setup if you had any desire to take a look at any configurations.


My response :

It looks like you are sending the emails from your internet connection at home?

Lots of email providers block email that is sent directly from
residential connections.

Can the box be configured to relay all email through the Time Warner
SMTP servers?

I believe a setting that should work for your connection is

Give that a try and your outgoing smtp relay and let me know if that works.


Yeah, that did the trick. I tried that but it had a slightly different smtp address.... and I didn't restart sendmail either.