Windows XP - Mozilla Firefox - Browser does not work after screen saver has been on

Discussion in 'General' started by popowich, Apr 14, 2013.

  1. popowich

    popowich EQ Forum Admin Staff Member

    Joined:
    Aug 12, 2008
    Messages:
    8,983
    Likes Received:
    120
    Hello,

    :thanks: in advance!

    I have a Windows XP related question that maybe someone can help with.

    Any time I come back to my computer and unlock the screen saver my Mozilla Firefox does not work.

    It acts like it either can't do DNS lookups or make connections to web sites. If I click any of the sites that had been open they do not respond. I do not get a connection timed out or other error, it just hangs there thinking.

    The semi solution is File -> Work offline, followed by File -> Work online

    That's enough to give Firefox a kick in the pants and make it start working again.

    FYI to others having this problem - You do not need to reboot to fix this issue.

    I see my instant messenger come back online when I login, so I think maybe my computer is turning off networking after some period of time in screen saver mode, but other applications on my computer are able to recover after seeing the network is back.

    I do not have power saving on except for turning off my monitors. My hard drives stay active. I do not have any form of hibernation enabled.

    I have done a bunch of Google reading. Others seem to have had this problem for a long time too.

    Any troubleshooting suggestions?
     


  2. THERESA

    THERESA Customer Service Staff Member

    Joined:
    Aug 12, 2008
    Messages:
    884
    Likes Received:
    11
    Comments from one of my friends:


    If the problem occurs in more than one browser, it could be several things. Power saving, a virus, a faulty or incorrectly configured network driver, etc. Try turning off all power saving features first. Also, make sure your computer has updated drivers and all of the patches and service packs from Microsoft.
     

  3. popowich

    popowich EQ Forum Admin Staff Member

    Joined:
    Aug 12, 2008
    Messages:
    8,983
    Likes Received:
    120
    My computer has been fixed for several days now.

    The solution was to adjust the power settings on my network adapter.

    Control Panel -> System, then:

    network power settings.JPG

    Hardware -> Right Click my Network Adapter and select Properties ->Uncheck the Power Saver options and OK
     
    Last edited by a moderator: Aug 8, 2013
  4. THERESA

    THERESA Customer Service Staff Member

    Joined:
    Aug 12, 2008
    Messages:
    884
    Likes Received:
    11
    Yes, that was one of the options I listed. :)
     
  5. popowich

    popowich EQ Forum Admin Staff Member

    Joined:
    Aug 12, 2008
    Messages:
    8,983
    Likes Received:
    120
    For whatever reason that response triggered me checking control panel -> power and the power saver options available from the screen saver settings screen. It took longer (and more problems) to get me to spend the time digging deeper and finding the related configuration for the network adapter driver.
     

Want to reply or ask your own question?

It only takes a minute to sign up (and it's free!). Click the orange sign up button to choose a username and then you can ask your own questions on the forum.
Loading...