Sunbelt Personal Firewall - Applying Computer Settings (Windows XP Login Stuck)

Discussion in 'General' started by popowich, Sep 12, 2011.

  1. popowich

    popowich EQ Forum Admin Staff Member

    Aug 12, 2008
    Likes Received:

    I've been experimenting with software firewalls on a Windows XP SP3 workstation connected to a Windows Domain. I had a surprisingly difficult time finding a firewall that wouldn't cause my workstation to crash on boot or completely block the network connection causing a login freeze (more than 60 minutes) after a reboot. I did not figure out the source of the problem, but I did come up with a workaround to get one of the firewalls installed and working correctly.

    First, if you are landing on this discussion because your Windows XP is stuck at a Window login screen such as "Applying computer settings..." one of the first troubleshooting steps to try is disconnecting the network cable from your computer. For me that causes an immediate timeout and Windows continues t load to my desktop. For some other firewalls such as Sygate Personal Firewall and Zone Alarm I needed to :

    • Boot into safe move
    • Move their folder from program files to temp so they couldn't load
    • Boot normally
    • Move the folder back to program files
    • Run a proper uninstall from the control panel
    Hope that helps! :)

    For the Sunbelt Personal Firewall disconnecting my network cable did the trick. As the desktop loaded Windows prompted me saying it had blocked some features within SPF. I clicked the button that said to unblock the features Windows had blocked automatically. After a reboot I still had long delays with my startup time. Unchecking and saving the setting for blocking connecting while windows is loading fixed the problem with my boot time :

    Sunbelt Personal Firewall - Applying Computer Settings Stuck.JPG

    Even with SPF unblocked by Windows security several of my programs, such as Microsoft Outlook 2010, still could not connect to the network. I tracked down the following setting (Hey SPF, make this the default!) that makes Sunbelt Personal Firewall act more like the Sygate Personal and Zone Alarm firewalls:

    Open the Sunbelt Personal Firewall settings and then :

    • Click Network Security in the left side navigation
    • Click on "any other program"
    • Click the Edit button
    • Change the preference for incoming connections to "Ask user"
    • Click OK to close the window
    • Click Apply and OK to save your new settings
    Sunbelt Ask User for Preferences.JPG

    With the above change instead of unexpected programs getting silently blocked in the background you'll be prompted with the option to block or allow them as they try to connect to the network, or as the network (such as other Windows servers you're communicating with) try to connect back to your workstation.

Want to reply or ask your own question?

It only takes a minute to sign up (and it's free!). Click the orange sign up button to choose a username and then you can ask your own questions on the forum.