Full-Session SSL at Live/Hotmail

Discussion in 'Hotmail' started by foggy, Nov 7, 2010.

  1. foggy

    foggy Valued Member

    Joined:
    Oct 23, 2010
    Messages:
    320
    Likes Received:
    23
    Hi,

    From an EMD discussion: this blog entry (about Hotmail features) includes in the comments a discussion of SSL and users there are saying they are able to use full time https access. See the comments there for url's and issues they are having.

    Better late than never. :)
     


  2. popowich

    popowich EQ Forum Admin Staff Member

    Joined:
    Aug 12, 2008
    Messages:
    8,999
    Likes Received:
    120
    I do not have anything prompting me to convert to "always use SSL"

    I also do not see such a setting in my Hotmail options.

    I commented on the Microsoft blog post a few days ago here - http://www.emailquestions.com/email...rosoft-your-pop3-email-account-passwords.html

    Microsoft's main objective appeared to be to get Hotmail / Live email users to use Hotmail for reading their Gmail and other pop3 accounts.

    I'm definitely against giving Hotmail access to my other email accounts.
     

  3. popowich

    popowich EQ Forum Admin Staff Member

    Joined:
    Aug 12, 2008
    Messages:
    8,999
    Likes Received:
    120
    I see, you must login from here - https://www.mail.live.com/

    That doesn't help people who type hotmail.com or have bookmarks to Hotmail.

    It really should be an option under Mail Options and there should be a notice at the top of the other Hotmail login pages letting users know that it is a feature.

    Unfortunately, it still does not work for me. I am told that HTTPS is not supported by my account type.
     
  4. foggy

    foggy Valued Member

    Joined:
    Oct 23, 2010
    Messages:
    320
    Likes Received:
    23
    Hi, Ray

    Yes, I got that notification, too (whatever it means). But after I get it, I just click on "Save" (with "Don't use https automatically" selected) and it takes me to my inbox with https showing in the address bar. Whatever that "account type" thing means, it doesn't prevent users from using full-time SSL. It's just that it has to be selected each time. At least that's the way it's been working for me this evening. :rolleyes:
     
  5. popowich

    popowich EQ Forum Admin Staff Member

    Joined:
    Aug 12, 2008
    Messages:
    8,999
    Likes Received:
    120
    I logged back in now and see that then https only setting did stick.

    It seems to be working for me for now.

    Great to see they are working on meaningful improvements! :D
     
  6. foggy

    foggy Valued Member

    Joined:
    Oct 23, 2010
    Messages:
    320
    Likes Received:
    23
    When I sign in (using the secure link you mentioned above) I'm always taken to the "Trying to use Hotmail with HTTPS?" page. But instead of clicking "always use https (recommended)" which always gets me the error message, I click the link next to it: continue to hotmail. It takes me to my Inbox but still with a https connection.

    Hopefully we'll soon find out (perhaps they'll have a blog entry tomorrow morning ?) what the 'account type' situation is. You may be right. Automatic https may only be for paying customers. Good ol' M$.
     
  7. popowich

    popowich EQ Forum Admin Staff Member

    Joined:
    Aug 12, 2008
    Messages:
    8,999
    Likes Received:
    120
    I have not been prompted again since.

    I can go check from another computer and see what happens...
     
  8. popowich

    popowich EQ Forum Admin Staff Member

    Joined:
    Aug 12, 2008
    Messages:
    8,999
    Likes Received:
    120
    I'm walked through the https setup again, but even with the error at the end I still seem to be full session https enabled.

    Hotmail - Always use HTTPS.JPG Hotmail - Connect with HTTPS.JPG
     
  9. foggy

    foggy Valued Member

    Joined:
    Oct 23, 2010
    Messages:
    320
    Likes Received:
    23
    Hi, Ray

    Yes, when I log in I see the first page (the one you have on the left). If I click the button "Always use..." it takes me to the second page (the one you have on the right). If from that page I click to use HTTPS automatically that's when I get the error message (every time).

    But if on the first page I click "Continute to Hotmail" or on the second page I click "Don't use HTTPS automatically" I am taken to my Inbox without any error message but with an HTTPS connection.

    So, the SSL/HTTPS connection 'holds' throughout my webmail session, but I still have to choose it manually every time. It's not going directly/automatically to my Inbox from my login page. (I now click "continue to Hotmail" on the first page immediately.)

    It's not a big deal, really. I'm glad they have finally implemented the more secure connection. (Yahoo, by contrast, is only now realizing how much their users want it since they're complaining about it being missing from the latest beta.) Still, I wish it wouldn't be so important to M$ to nickle-and-dime people with it: requiring a premium account for 'automatic' SSL (if that's what the 'account type' thing is all about) !
     
  10. foggy

    foggy Valued Member

    Joined:
    Oct 23, 2010
    Messages:
    320
    Likes Received:
    23
    Okay, as I thought, things got straightened out overnight. Specifically, Hotmail has now added an option in the options settings. Options > More Options > Managing Your Account > Account Details > Other Options. The last option under 'Other Options' is 'Connect Using HTTPS' and it does make it automatic at login. No more "wrong account type" message. :D
     
  11. popowich

    popowich EQ Forum Admin Staff Member

    Joined:
    Aug 12, 2008
    Messages:
    8,999
    Likes Received:
    120
    Yes, the new setting under Options -> More Options -> Manage your Account works for me too!

    Hotmail - Connect with HTTPS.JPG Hotmail - Use HTTPS Automatically.JPG

    :thanks: for the update!
     
  12. fearmydesign

    fearmydesign Valued Member

    Joined:
    Feb 12, 2009
    Messages:
    29
    Likes Received:
    0
    :confused: ..umnn... :( sorry but I don't undertstand the benefit I guess for me as a live/hotmail user. Can someone explain the benefit behind this thread, I'm not too technical... is it better to setup my live account with https?...

    Regards,
     
  13. popowich

    popowich EQ Forum Admin Staff Member

    Joined:
    Aug 12, 2008
    Messages:
    8,999
    Likes Received:
    120
    Recently there was a hack tool created called Firesheep that is easy for almost any regular windows user to install. More details can be foudn in this article: http://www.emailquestions.com/email-articles/2569-top-5-tips-prevent-your-email-getting-hacked.html

    The biggest problem is for people that access their Hotmail, Facebook, and other accounts that do not have https for all web pages enabled and connect to the internet at least some of the time to public wireless connections. It's less of a problem for users that have wired internet connections but regardless it's best to enable the setting if it does not cause a problem for any of your connection methods.

    If you access Hotmail using their web site you should enable the setting.

    If you connect to Hotmail using the Windows Live Mail desktop mail program making this change could cause a problem for that application.
     
  14. fearmydesign

    fearmydesign Valued Member

    Joined:
    Feb 12, 2009
    Messages:
    29
    Likes Received:
    0
    I made this change, but now I can't access my mail...why?? now when I go to hotmail.com and put in my login info, it stops and after a while displays an error 'The connection was reset'

    How can I revert this change or how do I access my live mail??

    Thanks
     
  15. popowich

    popowich EQ Forum Admin Staff Member

    Joined:
    Aug 12, 2008
    Messages:
    8,999
    Likes Received:
    120
    I see their ssl certificate does not work today if you try logging into Hotmail.com.

    Well, it will work, but you have to accept through some name mismatch errors.

    Try logging in from this link - https://www.mail.live.com/

    That worked for me with no errors.

    If it doesn't work for try that same link but from a different web browser.
     

Want to reply or ask your own question?

It only takes a minute to sign up (and it's free!). Click the orange sign up button to choose a username and then you can ask your own questions on the forum.
Loading...