Emails never being received no bounce

Discussion in 'Mail Server Support' started by xxkinetikxx, Jul 23, 2010.

  1. xxkinetikxx

    xxkinetikxx New Email

    Joined:
    Jul 23, 2010
    Messages:
    3
    Likes Received:
    0
    Hello all!

    Hoping someone here can lend me a hand with an ongoing email issues.

    Environment:
    Virtual Private Server: CENTOS 5.5, running WHM/Cpanel, with Dovecot & Spamassasin. Hosting several users/domains.

    Scenario
    First this is an intermittent problem. Or at least I know some email is coming/going.

    Outgoing emails are being "lost" in that someone from our server can email someone at another provider and the email is simply never received. We get no bounce back message, and the user cannot find it in their spam/junk folder.

    We have the same problem with incoming email. Whereas the using sending to us never receives a bounce back and we never receive the email.

    What I've Done Thus Far:
    I've checked blacklists & our SPF records and I cannot find a problem. I even paid for a DNSstuff.com subscription to help and everything is coming back clean from there as well.

    I've disabled HELO checks, and SpamAssassin. I'm not even getting the amount of spam I used to get (should be a good thing but not in this case).

    This environment was a move from a shared/reseller hosting packaged at Hostgator so I'm wondering if in the migration something happened.

    I'm wanting to blame DNS here but I'm just not savvy enough with Unix systems to really know how to diagnose this problem.


    Really stumped here.

    If anyone that can assist need more information please let me know and I'll be happy to provide you with anything I can.

    -Chris
     


  2. popowich

    popowich EQ Forum Admin Staff Member

    Joined:
    Aug 12, 2008
    Messages:
    9,002
    Likes Received:
    120
    Hi Chris,

    Which MTA are you running (qmail, sendmail, postfix, other?)

    Do you have access to the log files on the server?

    Can you find and post some of the logs that match the date and time of the missing emails?

    Is it possible that you have an email limit for your VPS and your web hosting provider is blocking your emails after X number of days?

    I doubt this problem is DNS related but I'll help double check it too. What is your domain name? What is the IP address of the server that sends your emails? I believe you expect to have the same server receiving your email and that it should be your MX record? Do you have a test email address?
     

  3. xxkinetikxx

    xxkinetikxx New Email

    Joined:
    Jul 23, 2010
    Messages:
    3
    Likes Received:
    0
    Exim

    Yes sir

    I'll give it a shot, is this what you are looking for?
    Code:
    	
    Line 20755: 2010-07-20 15:25:36 1ObIRY-00087G-Kj => USER@cox.net R=lookuphost T=remote_smtp H=mx.west.cox.net [68.6.19.3]
    Line 21417: 2010-07-20 16:48:24 1ObJjh-0000c5-MQ => USER@cox.net R=lookuphost T=remote_smtp H=mx.east.cox.net [68.1.17.3]
    Line 22091: 2010-07-20 19:30:50 1ObMGw-0005BW-5t <= USER@cox.net H=eastrmmtao105.cox.net [68.230.240.47] P=esmtp S=1635 id=20100720193048.XOI55.1148565.imail@eastrmwml41
    Line 34588: 2010-07-23 12:19:08 1OcKxX-0003zb-CW => USER@cox.net R=lookuphost T=remote_smtp H=mx.west.cox.net [68.6.19.3]
    
    That is all I could find related to a known missing email in the exim_mainlog
    I checked and this is not the case

    I'm currently hosting several domains as this was a move from a shared hosting environment. If it's ok with you I'd like to PM you the requested IP/Domain/Test email information?


    BTW :siterock:
     
  4. popowich

    popowich EQ Forum Admin Staff Member

    Joined:
    Aug 12, 2008
    Messages:
    9,002
    Likes Received:
    120
    Hi Chris,

    Sure, no problem, you can send me a PM with any info you don't want posted in the public forums.

    To confirm your outgoing IP is really what you think it is you can also send a test email from the server to {removed}

    :thanks:
     
  5. xxkinetikxx

    xxkinetikxx New Email

    Joined:
    Jul 23, 2010
    Messages:
    3
    Likes Received:
    0
    PM sent! Thank you very much.
     
  6. popowich

    popowich EQ Forum Admin Staff Member

    Joined:
    Aug 12, 2008
    Messages:
    9,002
    Likes Received:
    120
    Hello,

    I've been watching the server for a week now.

    I had nearly a 100% ping response for the week. General internet connectivity looks good.

    What is your queue size? You're actively on one RBL :

    Backscatterer.org powered by UCEPROTECT

    Which leads me to believe you are open to being abused by spammers. Do you see much spam in your queues? Are you able to enable valid recipient checking on your mail server? Do you expect to see the cox related emails? Are you being used to spam cox and others? If you can provide a current log sample and not sanitize it that might help to identify the problem. Here is some additional info about reading exim log files :

    Exim Specification - 51. Log files
     

Want to reply or ask your own question?

It only takes a minute to sign up (and it's free!). Click the orange sign up button to choose a username and then you can ask your own questions on the forum.
Loading...